Why am I getting logged off?

Discuss the forum itself.
Ole Juul
Posts: 30
Joined: Mon Jan 18, 2016 2:52 am

Why am I getting logged off?

Postby Ole Juul » Tue Dec 06, 2016 1:51 am

Every time I look, I've been logged off again. This despite checking the remember me box. Having to constantly log in makes the forum unnecessarily difficult to use. I don't need to do that on all the other forums I use.

verax
Site Admin
Posts: 30
Joined: Mon Jan 18, 2016 3:16 am

Re: Why am I getting logged off?

Postby verax » Tue Dec 06, 2016 2:39 am

Yes, I'm seeing the same problem. Timeout is really low, which is kind of annoying

User avatar
chip
T2 Operator
Posts: 41
Joined: Mon Jan 18, 2016 2:19 am
Location: Colorado, USA
Contact:

Re: Why am I getting logged off?

Postby chip » Tue Dec 06, 2016 2:47 am

We did an update to the most recent version and there does seem to be a short timeout on the cookies, it got set to a 0 day cookie expire time. I rolled back to the standard layout to get back to working.

Edit: I also set a rewrite rule to force SSL, a lack of which may have been affecting some of the cookies not being sent properly.
achip on #opennic | chip.geek

verax
Site Admin
Posts: 30
Joined: Mon Jan 18, 2016 3:16 am

Re: Why am I getting logged off?

Postby verax » Tue Dec 06, 2016 3:11 am

I don't think the rewrite rule is working, I'm still browsing in http

User avatar
chip
T2 Operator
Posts: 41
Joined: Mon Jan 18, 2016 2:19 am
Location: Colorado, USA
Contact:

Re: Why am I getting logged off?

Postby chip » Tue Dec 06, 2016 3:26 am

Are you accessing the site via talk.geek or talkdotgeek.com? The rewrite only happens on talkdotgeek.com as the cert for talk.geek is a self signed certificate and that may cause more headache than it's worth. I think the issue was more that the update set the cookie expire to 0 days, not a cookie-over-SSL issue.
achip on #opennic | chip.geek

verax
Site Admin
Posts: 30
Joined: Mon Jan 18, 2016 3:16 am

Re: Why am I getting logged off?

Postby verax » Tue Dec 06, 2016 3:37 am

Ah, I'm browsing from talk.geek, so that explains that.

User avatar
chip
T2 Operator
Posts: 41
Joined: Mon Jan 18, 2016 2:19 am
Location: Colorado, USA
Contact:

Re: Why am I getting logged off?

Postby chip » Tue Dec 06, 2016 3:45 am

Ya I didn't want a self-signed certificate warning being the first thing a user saw when getting to the site but SSL is available. Not ideal IMO but hopefully down the line there's a CA in the OpenNIC ecosystem.
achip on #opennic | chip.geek

verax
Site Admin
Posts: 30
Joined: Mon Jan 18, 2016 3:16 am

Re: Why am I getting logged off?

Postby verax » Tue Dec 06, 2016 3:53 am

Indeed. I think there's work on a letsencrypt style ca in progress, haven't heard about it in a while though. Definitely would be something useful


Return to “Meta”

Who is online

Users browsing this forum: No registered users and 1 guest